Search API performance issues: Storefront Search, Catalog API and Shop App experiencing degraded functionality

Incident Report for Shopify

Update

We continue to see recovery across Storefront and other Search API. We are continuing to monitor in order to ensure full resolution.
Posted Aug 03, 2026 - 17:07 EDT

Monitoring

We have noted recovery in the affected areas including storefront searches. We continue to monitor and will update you once full recovery is confirmed.
Posted Aug 03, 2026 - 15:51 EDT

Investigating

We are aware of an issue affecting Storefront Search, Catalog API and Shop app search functionality. This may produce inconsistent or no search results and intermittent timeouts. We are actively investigating and will update you on steps toward resolution.
Posted Aug 03, 2026 - 15:19 EDT
This incident affects: Admin, Storefront, and API & Mobile.