Some merchants and customers may encounter issues with with one or more of the following: admins, checkouts, storefronts, Retail POS. Access to Support also impacted.
We've identified the problem and are seeing recovery from our mitigation efforts. We will continue to monitor and update.
Posted Jun 03, 2026 - 10:37 EDT
Update
We are investigating and will keep you updated.
Posted Jun 03, 2026 - 09:45 EDT
Investigating
Merchants may experience issues when trying to access the Shopify admin and Retail POS. Customers may experience issues with accessing storefronts and checkouts. Access to Support also impacted.
Posted Jun 03, 2026 - 09:27 EDT
This incident affects: Admin, Checkout, Storefront, Support, and Point of Sale.