Some merchants and buyers may encounter error messages with one or more of the following: storefronts, checkouts

Incident Report for Shopify

Resolved

Between 00:30 UTC and 03:33 UTC, we experienced an infrastructural issue that resulted in errors across Shopify storefronts and checkouts. A fix was implemented at 03:33 which resolved the issue. The monitoring period for this issue has ended and no further impact has been observed.
Posted Jul 17, 2026 - 00:57 EDT

Monitoring

This issue has been resolved and is being monitored.
Posted Jul 17, 2026 - 00:45 EDT

Update

We've identified the problem and are seeing recovery from our mitigation efforts. We will continue to monitor and update.
Posted Jul 17, 2026 - 00:22 EDT

Identified

We've identified the problem impacting storefronts and checkouts, and we're working on a solution.
Posted Jul 16, 2026 - 23:02 EDT

Update

We're continuing to work on addressing the storefront and checkout issues, and will keep you updated.
Posted Jul 16, 2026 - 22:17 EDT

Investigating

Merchants and buyers may experience issues when trying to access Shopify storefronts, and attempting to check out. We are investigating and working to resolve these issues.
Posted Jul 16, 2026 - 22:02 EDT
This incident affected: Checkout and Storefront.