Shop Pay unavailable

Incident Report for Shopify

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 19:30 EDT

Update

Shop Pay is unavailable at this time, we are continuing to investigate and will update here when more information becomes available.
Posted Jun 24, 2025 - 19:15 EDT

Update

We are continuing to investigate, Shop Pay is unavailable at this time.
Posted Jun 24, 2025 - 19:15 EDT

Investigating

Shop Pay is currently unavailable. We’re investigating and will keep you updated.
Posted Jun 24, 2025 - 18:57 EDT
This incident affected: Checkout.