Subscribe to Updates
Subscribe
x
Visit our
support site
.
Multiple Shopify tools and systems are down
Incident Report for
Shopify
Resolved
This incident has been resolved.
Posted
Mar
12
,
2026
-
13:32
EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Mar
12
,
2026
-
12:39
EDT
Identified
The issue has been identified, and we are working on implementing a fix.
Posted
Mar
12
,
2026
-
12:19
EDT
Update
We have identified the issue and seeing recovery but will continue to stay on top of this until fully recovered.
Posted
Mar
12
,
2026
-
12:09
EDT
Update
We are continuing to investigate this issue.
Posted
Mar
12
,
2026
-
12:05
EDT
Investigating
We are currently aware of issues with access to admins, Shopify POS, and shopify.com not working as expected. We are working on a resolution.
Posted
Mar
12
,
2026
-
12:01
EDT
This incident affected: Admin, Checkout, Reports and Dashboards, Storefront, Support, and Point of Sale.
×
Subscribe to Incident
Subscribe to updates for
Multiple Shopify tools and systems are down
via . You'll receive .