Cloudflare Incident Impacting Various Shopify services

Incident Report for Shopify

Resolved

Between 11:00-16:10UTC, we experienced issues with Cloudflare. A fix was implemented by Cloudflare which resolved the issue. The monitoring period for this issue has ended and no further impact has been observed.
Posted Nov 18, 2025 - 13:02 EST

Monitoring

This issue has been resolved by Cloudfare and is being monitored.
Posted Nov 18, 2025 - 12:33 EST

Update

Investigations are ongoing and we will keep you updated.
Posted Nov 18, 2025 - 08:40 EST

Update

We are investigating and will keep you updated.
Posted Nov 18, 2025 - 07:22 EST

Investigating

Cloudflare experienced a widespread network outage that affected multiple Shopify services. Some customers may have encountered "internal service error" messages.

Please see the full post-mortem update for more details.
Posted Nov 18, 2025 - 06:57 EST
This incident affected: Storefront, Third party services, and Oxygen.